Building Windows Client - Client Crashes

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Building Windows Client - Client Crashes

shadowq
Hello,

I thought I had successfully built the ownCloud windows client, but it seems that after the ownCloud client is installed and configured, it crashes after syncing. When attempting to start it again, it begins the sync, and crashes again. Looking at the log file, it doesn't appear to have any error before the crash. I've seen this on a windows 8 and a windows 7 machine. However- I've also seen this work on a windows 8 and windows 7 machine. Initially I had made changes to the client, but to test- I built a fresh client (using the mirall 1.3 branch) and still experienced this problem.

Is there anything I can look for to give me clues?

The only things that look unsuccessful when building ocsync are:
-- Could NOT find CMocka (missing:  CMOCKA_LIBRARIES CMOCKA_INCLUDE_DIR)
-- Looking for argp.h - not found
-- Looking for nanosleep in rt - not found
-- Looking for clock_gettime in rt - not found
-- Looking for dlopen in dl - found
-- Looking for asprintf - not found
-- Looking for fnmatch - not found
-- Looking for timegm - not found
-- Looking for strerror_r - not found
-- Looking for utimes - not found
-- Looking for lstat - not found
CMake Warning:
  Manually-specified variables were not used by the project:
    SHARE_INSTALL_DIR

And for building mirall:
-- Could NOT find JPEG (missing:  JPEG_LIBRARY JPEG_INCLUDE_DIR)
-- Could NOT find TIFF (missing:  TIFF_LIBRARY TIFF_INCLUDE_DIR)
-- Could NOT find INOTIFY (missing:  INOTIFY_INCLUDE_DIR)
-- Could NOT find Sphinx (missing:  SPHINX_EXECUTABLE)

Should I be worried about these?

Thanks in advance!
Reply | Threaded
Open this post in threaded view
|

Re: Building Windows Client - Client Crashes

kwillems
This post was updated on .
As far as I know you shouldn't be worried about these. They are not needed. See this one: http://owncloud.10557.n7.nabble.com/help-needed-to-build-Mac-client-tp9221p9373.html

Are you sure you have the proper version of csync? With 1.3.0 you need v 0.80.0, http://git.csync.org/users/freitag/csync.git?h=dav
 
Reply | Threaded
Open this post in threaded view
|

Re: Building Windows Client - Client Crashes

Klaas Freitag-3
In reply to this post by shadowq
On 25.07.2013 10:48, shadowq wrote:

Hi,
>
> Should I be worried about these?

No, this seems all to be ok.

Your problem is probably that you use incompatible dlls with the exe.
The bundle we ship contains a whole lot of dlls which are copied along
with the client exe. Maybe you want to try to install a official client
and just replace the exe and the ocsync.dll and the module?

Another idea would be to use the tool depends.exe to find out which dlls
are used by your exe.

HTH
Klaas


_______________________________________________
Owncloud mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/owncloud
Reply | Threaded
Open this post in threaded view
|

Re: Building Windows Client - Client Crashes

shadowq
Thanks Klaas. I thought I would try building it on a physical machine (rather than the virtual machine I was using) just to be sure that wasn't causing any issues. However, I've now hit another problem- and can't compile the 1.3 branch (non-master) of mirall at all! I've posted another topic for that (http://owncloud.10557.n7.nabble.com/Can-no-longer-build-mirall-1-3-non-master-branch-td10290.html).

Thanks,
Jarrod.
Reply | Threaded
Open this post in threaded view
|

Re: Building Windows Client - Client Crashes

shadowq
In reply to this post by Klaas Freitag-3
Klaas Freitag-3 wrote
Maybe you want to try to install a official client
and just replace the exe and the ocsync.dll and the module?
I also tried installing the official client, and just copying in the owncloud.exe from my build, and it worked fine! How could I build the package with the dlls that are shipped with the official client?

Thanks,
Jarrod.