Debug slow webinterface (OC 6.0.0a)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Debug slow webinterface (OC 6.0.0a)

Tobias Brunner
Hi,

The webinterface on version 6.0.0a is loading very slow for me. From the
login page until everything is loaded it takes over 25s. I have other
webapplications running on the same server (f.e. roundcube) and they are
very fast. The server is running Debian Wheezy, PHP is loaded as Apache
module and PHP has the APC cache module enabled. There are only a few
default modules activated in ownCloud.

How can I debug this performance issue to find out where the bottleneck
is?

Thanks for any advice.

Cheers,
Tobias

_______________________________________________
Owncloud mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/owncloud
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

Otto Kekäläinen
I've noticed the same slowness thing in the web UI at multiple
installations. Can you open the web console (e.g. F12 on Chromium or
F12 for Firebug in Firefox) and see what request exactly is slow?
list.php?

What database do you run, SQLite?

2014/1/15 Tobias Brunner <[hidden email]>:

> Hi,
>
> The webinterface on version 6.0.0a is loading very slow for me. From the
> login page until everything is loaded it takes over 25s. I have other
> webapplications running on the same server (f.e. roundcube) and they are
> very fast. The server is running Debian Wheezy, PHP is loaded as Apache
> module and PHP has the APC cache module enabled. There are only a few
> default modules activated in ownCloud.
>
> How can I debug this performance issue to find out where the bottleneck is?
>
> Thanks for any advice.
>
> Cheers,
> Tobias
>
> _______________________________________________
> Owncloud mailing list
> [hidden email]
> https://mail.kde.org/mailman/listinfo/owncloud



--
Otto Kekäläinen
+358 44 566 2204
http://seravo.fi/
_______________________________________________
Owncloud mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/owncloud
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

Tobias Brunner
Hi,

> I've noticed the same slowness thing in the web UI at multiple
> installations. Can you open the web console (e.g. F12 on Chromium or
> F12 for Firebug in Firefox) and see what request exactly is slow?
> list.php?
>
> What database do you run, SQLite?

Yes, I'm using SQLite, or better, I WAS using SQLite. I've just switched
to MySQL and ownCloud is now MUCH faster!

Thanks for this hint...

Cheers,
Tobias

_______________________________________________
Owncloud mailing list
[hidden email]
https://mail.kde.org/mailman/listinfo/owncloud
anv
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

anv
In reply to this post by Otto Kekäläinen
Same problem: not a database problem. Not a webserver too busy.

See times: 47.95 seconds to load the page!

<http://owncloud.10557.n7.nabble.com/file/n12749/cap5.png>



--
View this message in context: http://owncloud.10557.n7.nabble.com/Debug-slow-webinterface-OC-6-0-0a-tp11737p12749.html
Sent from the Users mailing list archive at Nabble.com.
_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user
anv
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

anv
In reply to this post by Otto Kekäläinen
Same problem: not a database problem. Not a webserver too busy.

47.95 seconds waiting for the server respònse.





--
View this message in context: http://owncloud.10557.n7.nabble.com/Debug-slow-webinterface-OC-6-0-0a-tp11737p12750.html
Sent from the Users mailing list archive at Nabble.com.
_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user
anv
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

anv
In reply to this post by Otto Kekäläinen
Same problem: not a database problem. Not a webserver too busy.

See times: 47.95 seconds to load the page!

Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

Vincent Petry
Hi,

If it's the admin page I suspect it might be the WebDAV availability
check that isn't able to make a connection and waits for timeout...

Can you try setting "check_for_working_webdav" to false in config.php ?

Cheers,

Vincent

On 07/08/2014 08:52 AM, anv wrote:

> Same problem: not a database problem. Not a webserver too busy.
>
> See times: 47.95 seconds to load the page!
>
> <http://owncloud.10557.n7.nabble.com/file/n12751/cap5.png>
>
>
>
> --
> View this message in context: http://owncloud.10557.n7.nabble.com/Debug-slow-webinterface-OC-6-0-0a-tp11737p12751.html
> Sent from the Users mailing list archive at Nabble.com.
> _______________________________________________
> User mailing list
> [hidden email]
> http://mailman.owncloud.org/mailman/listinfo/user
>

_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user
anv
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

anv
Added 'check_for_working_webdav' => false, same result. My config.php contains this:

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxx',
  'datadirectory' => '/usr/share/owncloud/data',
  'dbtype' => 'mysql',
  'version' => '6.0.4.1',
  'dbname' => 'owncloud',
  'dbhost' => '127.0.0.1',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'owncloud',
  'dbpassword' => 'xxxxxxxxxxxxx',
  'installed' => true,
  'theme' => '',
  'maintenance' => false,
  'trusted_domains' =>
  array (
    0 => 'titan1.xxxxxxxxx',
    1 => 'titan2.xxxxxxxxx',
    2 => 'owncloud.xxxxxxxxx',
    3 => 'titan1',
    4 => 'titan2',
  ),
  'user_backends' =>
  array (
    0 =>
    array (
      'class' => 'OC_User_IMAP',
      'arguments' =>
      array (
        0 => '{192.168.100.4/notls:143}',
      ),
    ),
  ),
  'forcessl' => false,
  'maxZipInputSize' => 838860800,
  'allowZipDownload' => true,
  'loglevel' => '3',
  'check_for_working_webdav' => false,
);








Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

Vincent Petry
Is it only the admin page that is that slow or all pages ?

Maybe there's an app that is trying to do something that is blocking the
page. This is the page where many apps have their settings and some
might try to connect to remote sources for some reason.

Does the admin page load eventually ? Did you see any suspicious
app/values ? What apps do you have enabled ?

You could also try disabling apps one by one and see how it affects the
admin page.

Cheers,

Vincent

On 07/08/2014 09:38 AM, anv wrote:

> Added 'check_for_working_webdav' => false, same result. My config.php
> contains this:
>
> <?php
> $CONFIG = array (
>   'instanceid' => 'xxxxxxxxxxxxx',
>   'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxx',
>   'datadirectory' => '/usr/share/owncloud/data',
>   'dbtype' => 'mysql',
>   'version' => '6.0.4.1',
>   'dbname' => 'owncloud',
>   'dbhost' => '127.0.0.1',
>   'dbtableprefix' => 'oc_',
>   'dbuser' => 'owncloud',
>   'dbpassword' => 'xxxxxxxxxxxxx',
>   'installed' => true,
>   'theme' => '',
>   'maintenance' => false,
>   'trusted_domains' =>
>   array (
>     0 => 'titan1.xxxxxxxxx',
>     1 => 'titan2.xxxxxxxxx',
>     2 => 'owncloud.xxxxxxxxx',
>     3 => 'titan1',
>     4 => 'titan2',
>   ),
>   'user_backends' =>
>   array (
>     0 =>
>     array (
>       'class' => 'OC_User_IMAP',
>       'arguments' =>
>       array (
>         0 => '{192.168.100.4/notls:143}',
>       ),
>     ),
>   ),
>   'forcessl' => false,
>   'maxZipInputSize' => 838860800,
>   'allowZipDownload' => true,
>   'loglevel' => '3',
>   'check_for_working_webdav' => false,
> );
>
>
>
> <http://owncloud.10557.n7.nabble.com/file/n12753/cap6.png>
>
>
>
>
>
>
>
>
> --
> View this message in context: http://owncloud.10557.n7.nabble.com/Debug-slow-webinterface-OC-6-0-0a-tp11737p12753.html
> Sent from the Users mailing list archive at Nabble.com.
> _______________________________________________
> User mailing list
> [hidden email]
> http://mailman.owncloud.org/mailman/listinfo/user
>

_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user
anv
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

anv
2014-07-08 9:41 GMT+02:00 Vincent Petry <[hidden email]>:
Is it only the admin page that is that slow or all pages ?


All pages are slow
 
Maybe there's an app that is trying to do something that is blocking the
page. This is the page where many apps have their settings and some
might try to connect to remote sources for some reason.

Does the admin page load eventually ? Did you see any suspicious
app/values ? What apps do you have enabled ?

I enabled various apps what I've seen interesting. I Will try disabling apps. This will take some time because each click takes minutes...


_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

Steffen Lindner-2
In reply to this post by Vincent Petry
Is your owncloud.log file huge? I had the effect that the admin page
takes ages to load. Renaming the owncloud.log (was several MB) solved
the problem.

Cheers,
Steffen

On 08.07.2014 09:41, Vincent Petry wrote:

> Is it only the admin page that is that slow or all pages ?
>
> Maybe there's an app that is trying to do something that is blocking the
> page. This is the page where many apps have their settings and some
> might try to connect to remote sources for some reason.
>
> Does the admin page load eventually ? Did you see any suspicious
> app/values ? What apps do you have enabled ?
>
> You could also try disabling apps one by one and see how it affects the
> admin page.
>
> Cheers,
>
> Vincent
>
> On 07/08/2014 09:38 AM, anv wrote:
>> Added 'check_for_working_webdav' => false, same result. My config.php
>> contains this:
>>
>> <?php
>> $CONFIG = array (
>>   'instanceid' => 'xxxxxxxxxxxxx',
>>   'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxx',
>>   'datadirectory' => '/usr/share/owncloud/data',
>>   'dbtype' => 'mysql',
>>   'version' => '6.0.4.1',
>>   'dbname' => 'owncloud',
>>   'dbhost' => '127.0.0.1',
>>   'dbtableprefix' => 'oc_',
>>   'dbuser' => 'owncloud',
>>   'dbpassword' => 'xxxxxxxxxxxxx',
>>   'installed' => true,
>>   'theme' => '',
>>   'maintenance' => false,
>>   'trusted_domains' =>
>>   array (
>>     0 => 'titan1.xxxxxxxxx',
>>     1 => 'titan2.xxxxxxxxx',
>>     2 => 'owncloud.xxxxxxxxx',
>>     3 => 'titan1',
>>     4 => 'titan2',
>>   ),
>>   'user_backends' =>
>>   array (
>>     0 =>
>>     array (
>>       'class' => 'OC_User_IMAP',
>>       'arguments' =>
>>       array (
>>         0 => '{192.168.100.4/notls:143}',
>>       ),
>>     ),
>>   ),
>>   'forcessl' => false,
>>   'maxZipInputSize' => 838860800,
>>   'allowZipDownload' => true,
>>   'loglevel' => '3',
>>   'check_for_working_webdav' => false,
>> );
>>
>>
>>
>> <http://owncloud.10557.n7.nabble.com/file/n12753/cap6.png>
>>
>>
>>
>>
>>
>>
>>
>>
>> --
>> View this message in context: http://owncloud.10557.n7.nabble.com/Debug-slow-webinterface-OC-6-0-0a-tp11737p12753.html
>> Sent from the Users mailing list archive at Nabble.com.
>> _______________________________________________
>> User mailing list
>> [hidden email]
>> http://mailman.owncloud.org/mailman/listinfo/user
>>
>
> _______________________________________________
> User mailing list
> [hidden email]
> http://mailman.owncloud.org/mailman/listinfo/user
>
_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user
anv
Reply | Threaded
Open this post in threaded view
|

Re: Debug slow webinterface (OC 6.0.0a)

anv
In reply to this post by Vincent Petry
Just found the problem: an app (3d party: StorageCharts2)


2014-07-08 9:41 GMT+02:00 Vincent Petry <[hidden email]>:
Is it only the admin page that is that slow or all pages ?

Maybe there's an app that is trying to do something that is blocking the
page. This is the page where many apps have their settings and some
might try to connect to remote sources for some reason.

Does the admin page load eventually ? Did you see any suspicious
app/values ? What apps do you have enabled ?

You could also try disabling apps one by one and see how it affects the
admin page.

Cheers,

Vincent

On 07/08/2014 09:38 AM, anv wrote:
> Added 'check_for_working_webdav' => false, same result. My config.php
> contains this:
>
> <?php
> $CONFIG = array (
>   'instanceid' => 'xxxxxxxxxxxxx',
>   'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxx',
>   'datadirectory' => '/usr/share/owncloud/data',
>   'dbtype' => 'mysql',
>   'version' => '6.0.4.1',
>   'dbname' => 'owncloud',
>   'dbhost' => '127.0.0.1',
>   'dbtableprefix' => 'oc_',
>   'dbuser' => 'owncloud',
>   'dbpassword' => 'xxxxxxxxxxxxx',
>   'installed' => true,
>   'theme' => '',
>   'maintenance' => false,
>   'trusted_domains' =>
>   array (
>     0 => 'titan1.xxxxxxxxx',
>     1 => 'titan2.xxxxxxxxx',
>     2 => 'owncloud.xxxxxxxxx',
>     3 => 'titan1',
>     4 => 'titan2',
>   ),
>   'user_backends' =>
>   array (
>     0 =>
>     array (
>       'class' => 'OC_User_IMAP',
>       'arguments' =>
>       array (
>         0 => '{<a href="http://192.168.100.4/notls:143}" target="_blank">192.168.100.4/notls:143}',
>       ),
>     ),
>   ),
>   'forcessl' => false,
>   'maxZipInputSize' => 838860800,
>   'allowZipDownload' => true,
>   'loglevel' => '3',
>   'check_for_working_webdav' => false,
> );
>
>
>
> <http://owncloud.10557.n7.nabble.com/file/n12753/cap6.png>
>
>
>
>
>
>
>
>
> --
> View this message in context: http://owncloud.10557.n7.nabble.com/Debug-slow-webinterface-OC-6-0-0a-tp11737p12753.html
> Sent from the Users mailing list archive at Nabble.com.
> _______________________________________________
> User mailing list
> [hidden email]
> http://mailman.owncloud.org/mailman/listinfo/user
>

_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user



--

Qapla'
sɐƃɹɐΛ oɹpuɐɾǝl∀

_______________________________________________
User mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/user