Owncloud and Swift

Previous Topic Next Topic
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Owncloud and Swift

Joakim Öhman

We like Owncloud and we are evaluating it now for a project where we need to use Openstack Swift as the back-end storage.
Unfortunately the tests are not going very well and I hope to get some feedback on the stability of the Swift integration and if this is something for us to aim for.

1. First we tried the commercial version but Openstack Swift with Keystone authentication is not supported in that version so we moved on to community version 6.0.1

2. The web front seems to work fine, we can store and retrieve files but we get some errors in the log, see example below.

3. We tried the deleted files App and it works when you delete a file. You can find the deleted file but when you restore the file the restored file is 0 byte in size.
Feature request: When a file is deleted it is copied down to local disk, it would be great if it could stay on the source external storage instead.

4. Also tested the Windows and Linux client it seems to work fine until you try to sync something from the client to the server. We get the same error (Bad Request) on both the Linux and Windows client.
We can see that the file is copied to the Owncloud server but then removed again. The only thing we get in the server log is (we have enabled debug):
Error files_external Problem retrieving object [http://ops.elastx.net:8080/v1/AUTH_bd63fa06ddf9478d810d6fad00cce37f/owncloud-601/pull-to-eject-sign.jpg] 2014-02-17T09:23:11+00:00
Error files_external Problem retrieving object [http://ops.elastx.net:8080/v1/AUTH_bd63fa06ddf9478d810d6fad00cce37f/owncloud-601/pull-to-eject-sign.jpg/] 2014-02-17T09:23:11+00:00
Error files_external Problem retrieving object [http://ops.elastx.net:8080/v1/AUTH_bd63fa06ddf9478d810d6fad00cce37f/owncloud-601/pull-to-eject-sign.jpg] 2014-02-17T09:23:11+00:00

We haven't tried any more features, I think the above needs to work before we move on.

We tried all the above with local storage and then it works fine.
Below you can find some information about our environment.


Server configuration

Operating system: Centos 6.4

Web server: Apache 2.2.15

Database: mySQL 5.5.34

PHP version: 5.4

ownCloud version: 6.0.1

Updated from an older ownCloud or fresh install: Fresh

List of activated app:
Deleted files
External storage support
PDF Viewer
Share Files
Text Editor
Video Viewer

The content of config/config.php: (Without the database password and passwordsalt)
$CONFIG = array (
'instanceid' => 'xxx',
'passwordsalt' => 'xxx',
'datadirectory' => '/var/www/webroot/ROOT/data',
'dbtype' => 'mysql',
'version' => '',
'dbname' => 'owncloud',
'dbhost' => 'xxx',
'dbtableprefix' => 'oc_',
'dbuser' => 'owncloud',
'dbpassword' => 'xxx',
'installed' => true,
'loglevel' => '1',
'forcessl' => true,

Are you using external storage, if yes which one:
Openstack Swift

Client configuration

Browser: Chrome

Operating system: Ubuntu / Windows 7

Owncloud client version


Joakim Öhman
Elastx | Public and Private PaaS
office: +46 8 557 728 10
mobile: +46 725 717801
skype: joakim.24
twitter: @Elastx

Devel mailing list
[hidden email]