Problem with accented characters

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with accented characters

Mauricio Piacentini
Hi, people. I am testing version 1.0, and found a number of issues.
What is the correct address for bug reports? I am sending some here:

A) On all pages I get a line saying: <b>Notice</b>:  Uninitialized
string offset:  0 in
<b>/home/vhostadmin/www/owncloud/inc/lib_base.php</b> on line
<b>59</b><br />

I imagine this is related to running owncloud on a subdirectory of the
webserver, mapped to a virtual name.

B) When you upload a file that has accents on the name it will get
created in data. But you can no longer load the file browser: clicking
on files will display nothing. Deleting the file from the data
subdirectory makes it possible to view the other files again. Test
with a file named "Question?rio n?mero1.doc"

C) When you upload a file with spaces in the filename ("foo bar.doc")
then it will be displayed, but when you download the SAVE AS dialog in
the browser will only show "foo" as the suggested filename.

D) Click on MORE ACTIONS. Now create a folder. Without closing the
more actions subwindow, select the folder in the main pane. Try to
upload a file. It will be uploaded into root. Now click MORE ACTIONS
again to hide it. Click again to display it, after navigating to the
folder you have created. Now the upload will occur to the right
location.

BTW, I am using SQlite as the backend, Debian Lenny on the server. I
would love to help development, hope to catch some of you during
Akademy.

Regards,
Mauricio Piacentini

Reply | Threaded
Open this post in threaded view
|

Problem with accented characters

Robin Appelman
On Tuesday, June 29, 2010 02:45:11 Mauricio Piacentini wrote:

> Hi, people. I am testing version 1.0, and found a number of issues.
> What is the correct address for bug reports? I am sending some here:
>
> A) On all pages I get a line saying: <b>Notice</b>:  Uninitialized
> string offset:  0 in
> <b>/home/vhostadmin/www/owncloud/inc/lib_base.php</b> on line
> <b>59</b><br />
>
> I imagine this is related to running owncloud on a subdirectory of the
> webserver, mapped to a virtual name.
Yes, that is probably the case here, this should already be fixed in git.

>
> B) When you upload a file that has accents on the name it will get
> created in data. But you can no longer load the file browser: clicking
> on files will display nothing. Deleting the file from the data
> subdirectory makes it possible to view the other files again. Test
> with a file named "Question?rio n?mero1.doc"
>
> C) When you upload a file with spaces in the filename ("foo bar.doc")
> then it will be displayed, but when you download the SAVE AS dialog in
> the browser will only show "foo" as the suggested filename.
This is probably due to the way the browser handles the filename header, there
are more glitches like that, iirc chrome changes the extension with .html and
konq seems to pay little attention to it at all
>
> D) Click on MORE ACTIONS. Now create a folder. Without closing the
> more actions subwindow, select the folder in the main pane. Try to
> upload a file. It will be uploaded into root. Now click MORE ACTIONS
> again to hide it. Click again to display it, after navigating to the
> folder you have created. Now the upload will occur to the right
> location.
Oops, I overlooked the More Actions when I changed the file browser to not
redraw everything when changing folders, will fix it.
>
> BTW, I am using SQlite as the backend, Debian Lenny on the server. I
> would love to help development, hope to catch some of you during
> Akademy.
help is always welcome, just pop by in the mailing list, irc or tampere
>
> Regards,
> Mauricio Piacentini
> _______________________________________________
> Owncloud mailing list
> Owncloud at kde.org
> https://mail.kde.org/mailman/listinfo/owncloud