WebDAV problem

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

WebDAV problem

Damjan Gerl
This text I write some months ago to the ouncloud forum, but have
receive a response to try to post the question to the developers, so I'm
here:
-------------------
Hi to all! I have recently discovered ownCloud and install it on a web
server (of my domain with linux/apache hosted by aruba.it). All works ok
and then I try to configure a WebDAV plugin on my home pc win program
TotalCommander to send/receive files. Here I find a problem on sending
files that don't work: every PUT command return a error "501 Not
Implemented". After some discussion/testing with TotalCommander plugin
users/developers and after testing that with OwnCloud own client work
ok, but with another WebDAV prog CarotDAV have the same problem we
sorted the problem in "that my server doesn't like Content-Type header".
After installing a modified version of plugin that don't use
content-type all work ok. And here is my question: is this a known
problem, or maybe a bug or maybe also a problem of my server
(configuration etc.)? What can I do to solve the problem on "server"?

Here [0] it is the link to TotalCommander forum with discussion on this
problem. I have owncloud 5.0.10 php 5.3.27 on an apache/linux server.
-------------------

I have recently installed the last version of oc 6.0.1 and the problem
is the same. Can this problem be managed in ownCloud?

Thank you!
Damjan G.

[0] http://ghisler.ch/board/viewtopic.php?p=272593
_______________________________________________
Devel mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/devel
Reply | Threaded
Open this post in threaded view
|

Re: WebDAV problem

Jan-Christoph Borchardt-4
The developer mailing list is _not_ for support requests. Please use the issue tracker, forum or [hidden email] mailing list for that.

The developer list is for developer and development discussion.

Thanks! :)

On Feb 13, 2014 12:19 AM, Damjan Gerl <[hidden email]> wrote:

>
> This text I write some months ago to the ouncloud forum, but have
> receive a response to try to post the question to the developers, so I'm
> here:
> -------------------
> Hi to all! I have recently discovered ownCloud and install it on a web
> server (of my domain with linux/apache hosted by aruba.it). All works ok
> and then I try to configure a WebDAV plugin on my home pc win program
> TotalCommander to send/receive files. Here I find a problem on sending
> files that don't work: every PUT command return a error "501 Not
> Implemented". After some discussion/testing with TotalCommander plugin
> users/developers and after testing that with OwnCloud own client work
> ok, but with another WebDAV prog CarotDAV have the same problem we
> sorted the problem in "that my server doesn't like Content-Type header".
> After installing a modified version of plugin that don't use
> content-type all work ok. And here is my question: is this a known
> problem, or maybe a bug or maybe also a problem of my server
> (configuration etc.)? What can I do to solve the problem on "server"?
>
> Here [0] it is the link to TotalCommander forum with discussion on this
> problem. I have owncloud 5.0.10 php 5.3.27 on an apache/linux server.
> -------------------
>
> I have recently installed the last version of oc 6.0.1 and the problem
> is the same. Can this problem be managed in ownCloud?
>
> Thank you!
> Damjan G.
>
> [0] http://ghisler.ch/board/viewtopic.php?p=272593 
> _______________________________________________
> Devel mailing list
> [hidden email]
> http://mailman.owncloud.org/mailman/listinfo/devel 
_______________________________________________
Devel mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/devel
Reply | Threaded
Open this post in threaded view
|

Re: WebDAV problem

Klaas Freitag-3
On 13.02.2014 08:13, Jan-Christoph Borchardt wrote:
Hi,

> The developer mailing list is _not_ for support requests. Please use the issue tracker, forum or [hidden email] mailing list for that.
Thanks for your protection, but I think we should be relaxed.
This one is indeed something that could be discussed on the devel list
as there seems to be something fishy with the way we handle the
Content-Type header.

I think the Content-Type header should not prevent the server from
accepting a PUT, but we have had related issues in the past, see
https://github.com/owncloud/mirall/issues/1124

I fixed that by actually adding the Content-Type to the PUT request. Not
sure if that helps you out here, but it might be a hint.

Of course a bug report can not harm, I am not sure if Evert, who is the
master of the WebDAV implementation, reads the list.

 > The developer list is for developer and development discussion.
oh yeah, indeed :-)

regards,

Klaas

>
> Thanks! :)
>
> On Feb 13, 2014 12:19 AM, Damjan Gerl <[hidden email]> wrote:
>>
>> This text I write some months ago to the ouncloud forum, but have
>> receive a response to try to post the question to the developers, so I'm
>> here:
>> -------------------
>> Hi to all! I have recently discovered ownCloud and install it on a web
>> server (of my domain with linux/apache hosted by aruba.it). All works ok
>> and then I try to configure a WebDAV plugin on my home pc win program
>> TotalCommander to send/receive files. Here I find a problem on sending
>> files that don't work: every PUT command return a error "501 Not
>> Implemented". After some discussion/testing with TotalCommander plugin
>> users/developers and after testing that with OwnCloud own client work
>> ok, but with another WebDAV prog CarotDAV have the same problem we
>> sorted the problem in "that my server doesn't like Content-Type header".
>> After installing a modified version of plugin that don't use
>> content-type all work ok. And here is my question: is this a known
>> problem, or maybe a bug or maybe also a problem of my server
>> (configuration etc.)? What can I do to solve the problem on "server"?
>>
>> Here [0] it is the link to TotalCommander forum with discussion on this
>> problem. I have owncloud 5.0.10 php 5.3.27 on an apache/linux server.
>> -------------------
>>
>> I have recently installed the last version of oc 6.0.1 and the problem
>> is the same. Can this problem be managed in ownCloud?
>>
>> Thank you!
>> Damjan G.
>>
>> [0] http://ghisler.ch/board/viewtopic.php?p=272593
>> _______________________________________________
>> Devel mailing list
>> [hidden email]
>> http://mailman.owncloud.org/mailman/listinfo/devel
> _______________________________________________
> Devel mailing list
> [hidden email]
> http://mailman.owncloud.org/mailman/listinfo/devel
>

_______________________________________________
Devel mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/devel
Reply | Threaded
Open this post in threaded view
|

Re: WebDAV problem

Damjan Gerl
13.02.2014 - 9:49 - Klaas Freitag:

> This one is indeed something that could be discussed on the devel list
> as there seems to be something fishy with the way we handle the
> Content-Type header.
>
> I think the Content-Type header should not prevent the server from
> accepting a PUT, but we have had related issues in the past, see
> https://github.com/owncloud/mirall/issues/1124
>
> I fixed that by actually adding the Content-Type to the PUT request.
> Not sure if that helps you out here, but it might be a hint.
>
> Of course a bug report can not harm, I am not sure if Evert, who is
> the master of the WebDAV implementation, reads the list.
>
> regards,
>
> Klaas

Thank you for consideration! Also if I temporarily resolve the problem I
will be happy if this "bug" can be resolved in OwnCloud. I will do a bug
report.

BR,
Damjan G.

>
>>
>> Thanks! :)
>>
>> On Feb 13, 2014 12:19 AM, Damjan Gerl <[hidden email]> wrote:
>>>
>>> This text I write some months ago to the ouncloud forum, but have
>>> receive a response to try to post the question to the developers, so
>>> I'm
>>> here:
>>> -------------------
>>> Hi to all! I have recently discovered ownCloud and install it on a web
>>> server (of my domain with linux/apache hosted by aruba.it). All
>>> works ok
>>> and then I try to configure a WebDAV plugin on my home pc win program
>>> TotalCommander to send/receive files. Here I find a problem on sending
>>> files that don't work: every PUT command return a error "501 Not
>>> Implemented". After some discussion/testing with TotalCommander plugin
>>> users/developers and after testing that with OwnCloud own client work
>>> ok, but with another WebDAV prog CarotDAV have the same problem we
>>> sorted the problem in "that my server doesn't like Content-Type
>>> header".
>>> After installing a modified version of plugin that don't use
>>> content-type all work ok. And here is my question: is this a known
>>> problem, or maybe a bug or maybe also a problem of my server
>>> (configuration etc.)? What can I do to solve the problem on "server"?
>>>
>>> Here [0] it is the link to TotalCommander forum with discussion on this
>>> problem. I have owncloud 5.0.10 php 5.3.27 on an apache/linux server.
>>> -------------------
>>>
>>> I have recently installed the last version of oc 6.0.1 and the problem
>>> is the same. Can this problem be managed in ownCloud?
>>>
>>> Thank you!
>>> Damjan G.
>>>
>>> [0] http://ghisler.ch/board/viewtopic.php?p=272593

_______________________________________________
Devel mailing list
[hidden email]
http://mailman.owncloud.org/mailman/listinfo/devel