the problem in compiling windows client

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

the problem in compiling windows client

scott
Recently I am compiling owncloud client for windows with the cross-compile environment.But I have suffered some mistakes that I can not handle.I follow the step that shows in http://doc.owncloud.org/desktop/1.4/building.html

And I download some dependencies that it need.Now I am sure I have installed all the dependencies.But when I run the command ‘cmake -DCMAKE_BUILD_TYPE="Debug" ../mirall \
      -DCSYNC_BUILD_PATH=/home/hadoop/forwin/ocsync-build \
      -DCSYNC_INCLUDE_PATH=/home/hadoop/forwin/ocsync/src‘


It shows it can not find the qtkeychain,although I have alreadly installed it.Considering this ,I add the path in the command:
cmake  -DCMAKE_BUILD_TYPE="Debug" ../mirall \
      -DCSYNC_BUILD_PATH=/home/hadoop/nn/ocsync-build \
      -DCSYNC_INCLUDE_PATH=/home/hadoop/nn/ocsync/src \
      -DQTKEYCHAIN_INCLUDE_DIR=/usr/i686-w64-mingw32/sys-root/mingw/include/keychain \
      -DQTKEYCHAIN_LIBRARY=/usr/i686-w64-mingw32/sys-root/mingw/lib/
Now it can be found,but when I run ’mingw32-make‘,it shows

Also it can not find the qtkeychain/keychain.h,but acctually it exist in /usr/i686-w64-mingw32/sys-root/mingw/include/keychain \.

I have seared a lot but there is no right answer to handle it .Any ideas?